Is it okay to use plugins that are not current with latest version of WordPress?

People often ask me whether it is safe to run plugins that are not tested with the latest version of WordPress. And it's a good question, because software in general is something that you want to keep current and updated with all the latest. For WordPress plugins however, there are many plugins that simply don't need to be updated with each new version of WordPress.

The answer? It depends..

A safe answer for the general case would be that, unless there are known security or other outstanding issues, it may be fine but really depends on the


World of WordPress is hosted by:

Rocket.net: Build Your Site on the Fastest WordPress Platform

With Rocket, your websites will be blazing fast, always protected, and supported 24/7 by our experts with over 17 years of experience.