WordPress 5.5 Update Breaks Plugins – How to Fix it with jQuery Migrate Helper?

WordPress 5.5 “Eckstine” brings a lot of awesome changes to the core. Removing the jQuery Migrate 1.x in WP 5.5. was one of the planned stages in terms of updating the jQuery version.

Despite the recommendation for developers to get ready for this jQuery update by testing and updating their code, this update still has caught many developers unprepared.

The JavaScript library update has virtually broken many plugins, leaving WP users with messed-up Yoast, Social Warfare and even the Classic WordPress Editor plugins. Many users of these popular plugins have been reporting numerous issues.

Have some of your WordPress plugins


World of WordPress is hosted by:

Servebolt: next level high performance hosting.

While others try to add more components to their hosting to make it go faster, we decided to build our hosting cloud fast from the ground up. We did so by stripping out everything we knew was deadweight.